Cannot connect to development CRM

Oct 28, 2009 at 4:15 PM

I have a couple of CRM organisations within our company - one is the live environment and the other is our development site. Using this tool I can connect to our live server without any issues (this is held on a seperate server to our development setup) however, I cannot seem to connect to our development setup. The live site has been configured for IFD but the development org hasn't (not sure if ths makes any difference).

I have the tool setup with the internal server name of the development server, a user that should be working on it and the authentication type set to AD (as all the accounts are from an AD environment). We can log onto the development CRM without any problems normally but not when using this tool. When I try to connect I receive the following error:

Failed to Login: The request failed with HTTP status 404: Not Found

Any ideas?


Oct 29, 2009 at 9:42 AM


Try to surf to <<servername>>/MSCRMServices/2007/AD/CrmDiscoveryService.asmx via the internet explorer.

If that doesn't work try <<servername>>/MSCRMServices/2007/SPLA/CrmDiscoveryService.asmx


If the first one doesn't work but the second one does try setting the authentication type to OnPremise instead of AD.


If neither works the server name is wrong :-S


Let me know if this worked for you



Oct 29, 2009 at 10:01 AM
Edited Oct 29, 2009 at 10:02 AM

Thanx Wim

I tried as you suggested by surfing to the AD connection service and receive this back:


The following operations are supported. For a formal definition, please review the Service Description.

  • Execute
    Executes requests using a message-based approach. The Execute method takes a message request class as a parameter and returns a message response class.

So I assume that AD is working as expected (you may see differently) but I still cannot seem to connect to this server using your tool. I'm not entirely convinced the the development server is setup correctly as I can only access the CRM using localhost whilst on it directly (I can access the site from a network workstation by using the DNS entry for the server name) but I've also tried to connect to the server locally and on a network worksation using your tool but neither seem to get anywhere with it unfortunately.


Any other ideas I could try?


Oct 29, 2009 at 10:33 AM

Hi Wim

Think I have this sorted now. There was a missing Host Header in IIS. Once I added this I appear to be connecting properly now.