Contacts not Updating

Oct 9, 2009 at 10:40 AM

Hi

This is a great tool however I have created a CSV with the following columns

Contactid firstname lastname parentcustomerid
316B7D83-5C8E-DE11-B5C3-005056A86676 Dave Hind account,620c7e68-5c8e-de11-b5c3-005056a86676

The GUIDS are correct (after painstakingly matching them up) but what is happening is that instead of updating the existing contacts, the tool is creating new contacts that contain first, last name and teh parent customer but I want it to update the existing contacts.

What am I doing wrong?

thanks

Allan

Coordinator
Oct 9, 2009 at 1:55 PM
Edited Oct 9, 2009 at 1:56 PM

Hi Allan,

 

If you are sure about the contactid you're not doing anything wrong.

This does however sounds like the bug I Fixed between version 2.3 and 2.4 so i would recommend downloading the new version(2.4) and try again.

 

Let me know if this worked for you :-)

Grtz

Wim

 

Oct 9, 2009 at 2:06 PM

Hi Wim

 

Thanks for your quick response, however I have just re downloaded the new version and I am still getting a new contact created with the parent company rathe rather than an updated existing contact.  I have also double checked teh contact GUID in CRM that I have on teh CSV and they match.

 

Any help you can provie is most appreciated!

 

Cheers

 

Allan

Coordinator
Oct 9, 2009 at 4:24 PM
Hi allan,

I dont really have any idea then. I'll test it on our environments on
monday with a similar scenario.

I'll keep you informed

Have a nice weekend

Wim
Coordinator
Oct 12, 2009 at 8:55 AM

Hi Allen,

 

I just tested your scenario, and it seems to work perfectly as expected.

If i look at the data you provided (ie: 316B7D83-5C8E-DE11-B5C3-005056A86676 Dave Hind account,620c7e68-5c8e-de11-b5c3-005056a86676)

the first thing i would like to ask is : are you using the full name field as one of the columns ??? this is a calculated column so that won't work.

another thing is : instead of manually matching the contact id's, try to do a GET FROM CRM > EXPORT TO CSV. this way you'll be sure to have the correct ID's.

 

A quick test can be done with the following steps:

* Create two contacts with test as a first name and a random account as the parentcustomer account.

* Create an advanced find view in CRM with the following columns: ContactId, Firstname, Lastname, Parentcustomerid, make it so the first name is equal to "test" and save the Advanced find view

* next in the CRMUpdater tool do a GET FROM CRM with as the entity contact and the query your advanced find view.

* EXPORT TO CSV

* Open the CSV in Excel or notepad and switch the parent customer ID for the first two records.

* back in the CRMUpdater do a GET FROM CSV

* EXPORT TO CRM

 

 

Let me know if it worked.

Oct 13, 2009 at 10:48 AM

Hi Wim

I got it to work in the end thanks!  First thing I did was remove the full name (stupid me!) and then after a bit of fiddling around I created a new viw that showed all active contacts and their parent customerid

I exported this using the tool, then deleted the contents and inserted my list with correct guids.  Saved the csv then did the import, so it was, i think the view i was using that it didnt like, but glad to say it all worked and it s a great tool.

 

It will save a lot of people a lot of time, thanks for your help!

 

Allan

Dec 15, 2009 at 4:32 PM

hi Wim,

I'm having a similar problem to what Allan had. I've followed the instructions above but it hasn't resolved it.

I'm using CRM Online and want to update the parentcustomerid of some contacts. I downloaded the accounts, the contacts matched them in excel and created a view in CRM and basically did as you have above but no contacts are getting updated. When I load the CSV and 'upload to CRM' the program goes through each, turning them green but nothing is updating in CRM.

Sample of what I'm uploading:

"contactid", "parentcustomerid", "lastname"
"b9f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "lastname1"
"b7f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "lastname2"
"b8f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "lastname3"

 

"contactid", "parentcustomerid", "lastname"
"b9f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "Dickson"
"b7f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "R. Johnson, FCCA"
"b8f9e955-19e4-de11-896e-02bf0a064bea", "account,00968794-19e4-de11-b926-02bf0a064bea", "W. Carson, CA, CMA"

I also doing the test, as you described above but again, nothing get updated in CRM. 

Any help would be greatly appreciated.

regards,

James