"Failed to login" for CRM Live

Apr 14, 2009 at 12:38 AM
First, this looks like a great tool - many thanks for sharing it. It looks like it addresses exactly the problem we are having.

[The problem is: we can bulk import new records with lookup fields that refer to our custom entities (simply by using the text for the custom entity in the CSV file), and we can use the bulk import "enrich data" option with the GUID/key in the CSV file to bulk update non-lookup fields. However, trying to do the same with lookup fields to custom entities gives a "The record is empty" failure. We can't use either the text or the GUID in the import files - neither works]

We are using Dynamics CRM 4.0 Online, using Microsoft Passport login. However I can't seem to use the tool to login. I have put the CRM Live URL (https://XXX.crm.dynamics.com) as the server, my Windows live username "XXX.XXX@XXX.com" and password into the appropriate boxes, selected ''Authentication type= passport", and left domain and instance blank. It shows "Creating Services..." for a few seconds, then gives the dialog box "Failed to login". I have the Microsoft CRM 4.0 full install for Outlook, which works fine for Outlook sync and also extraction of data into Excel for editing.

Any ideas on how to get login working with CRM Online?

Many thanks,
David

Coordinator
Apr 14, 2009 at 10:23 AM
Hi David,

Thanks for the input... I do not have a CRM Online at my disposal so i can't test the connection and such...

So maybe you can do some tests for me :-)
I'll try to get the code ready by the end of the week and let you know where you can find a testable version.

Greetz

Wim.
Apr 14, 2009 at 3:15 PM
Wim - many thanks for your very fast reply. I absolutely will run tests for you to help get this working with CRM Online - it looks like it would be extremely useful for us.

Look forward to hearing from you in due course.

Cheers,
David

May 13, 2009 at 7:28 PM

Hi Wim - did you get a chance to look at getting a version working with CRM Online?

Cheers,
David

 

Coordinator
Jun 8, 2009 at 12:45 PM

David,

I'm currently on a holiday, but I think i should have a version for you that MIGHT work on CRM online around wednesday next week to test if your still interested.

I'll contact you through your email when i have a testable version.

 

Greetz

Wim

Jun 8, 2009 at 6:24 PM

Hi Wim,

I would be very interested in getting a version that works with CRM online. We still have not found a way to bulk update our customized lookup attributes correctly.

I will test just as soon as you can get me an updated version. Will look for your email - many thanks.

Cheers,
David

 

Coordinator
Jul 17, 2009 at 9:58 AM

David,

Still not up and running and work here picked up again so less time to do the open source stuff :-S

I was wondering if you could provide me with an test account (can be read only to one (custom) entity, if you don't want me to see your data) so that i can  test it myself... )

The login principal has changed alot for crm online, so just writing some code and mailing it to you would be quite tedious.

Is this an option?

 

Thanks

Aug 28, 2009 at 2:58 AM

Hi Wim,

I just tried the latest version, release 2.2, with CRM Online, and it now works.

Login is:

Server: https://<oursite>.crm.dynamics.com/
Username: my Windows Live email address
Password: my Windows Live password
Domain: <blank>
Authentication type: Passport
Instance: <oursite>

I have the CRM Outlook add-in installed, so I didn't need to copy the contents of "assemblies" to %windir%\assembly - they were already there. Just as well - this didn't seem to work properly using file copy from Explorer under Vista. However, I did copy msidcrl40.dll to %windir%\system32

Many thanks! This tool is exactly what we have been looking for.

Cheers,
David